Jubler Subtitle Εditor

Information about installing Jubler on Snow Leopard.

To use Jubler you need at least JDK 1.7. Unfortunately there is no such bundle for Mac OS 10.6. Still, thanks to Wyatt8740 ,there is a version available for you (also leave him a positive feedback!). Steps to install it:

It is recommended to leave the preferences as is. Let the newest version be the default instead of the older 6 version.